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How to Use Eclipse with OpenGTS project

It's possible to use Eclipse IDE with OpenGTS project, in this document I'll explain how.
This document was written and tested for Linux and Windows environment(tested on Windows XP

and Windows 7 x64).

Prerequisites

The system must be setup according OpenGTS Installation/Configuration manual

(OpenGTS_Config.pdf inside OpenGTS packages)
You must be able to compile correctly the package using command line before continue (ant all).

Eclipse Installation

* Download Eclipse IDE for Java EE Developers, this package has built in all plugins
needed to develop Tomcat servlet. (http://www.eclipse.org/downloads/).
Linux: eclipse-jee-ganymede-SR1-linux-gtk.tar.gz
Windows: eclipse-jee-ganymede-SR1-win32.zip

e Untar or unzip the downloaded file then run eclipse

*  When prompted select a workspace directory, then mark the checkbox to avoid to show this
question every time eclipse startup.

Linux: We are assuming /home/user/ is your home directory in Linux environment

= Workspace Launcher *

Select a workspace

Eclipse Platform stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: | /home/user/workspace w Browse...

[v] Use this as the default and do not ask again
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http://www.eclipse.org/downloads/

Windows:

-
= Workspace Launcher

= TN .

Select a workspace

Choose a workspace folder to use for this session.

Eclipse 5DK stores your projects in a folder called a workspace.

Workspace:  [:\Proj ectsi'aEcIipse

[ Use this as the default and do not ask again

Remember to uncheck Automatic Build.

Project | Run  Window Help

File Edit Source Refactor Mavigate Search
F“"j’ - ﬁ; - ﬂ - % - '@

. { e |

£ Package Exp EEN\K:E: Hierarch],r'i 8

T

Open Project

Close Project

= =

Build All
Build Project
Build Working 5et

Clean...

&) Generate Javadoc...

Properties

Ctrl+B

Build Automatically |

£
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Create a new Project

* Click on File -> New -> Project.
According your Eclipse installation this windows maybe differ sligthly

Java - Eclip

Edit Source Refactor MNavigate Search Project Run Window Help

2% Java Project

Open File...

H#¥ Package

* Select Java Project then click Next button.

New Project

Select a wizard

Create a Java project [

Wizards:

e

)>]

> = General

P = CVS

P (= Eclipse Modeling Framework

b = EJB

- [= |ava L4
# Java Project from Existing Ant Buildfile

P (= Java EE

P T lmwvsSerint
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* Assign a name to the project: OpenGTS
* In Contents area select Create new project in workspace
* In JRE area select Use a project specific JRE
Be Aware!! Select ONLY SUN JDK, others doesn't works!!
Fedora starting from Relase 10 uses java-1.6.0-openjdk 1.6.0-devel that works too.
* Select Create separate folder for sources and class files

e New Java Project X
Create a Java Project —
Create a Java project in the workspace or in an external location.

Project name: OpenGTS

Contents

® Create new project in workspace

' Create project from existing source

JRE
) Use default |RE (Currently 'jdk1.5.0_17') Configure |REs...
® Use a project specific JRE: jdk1.5.0_17 w

' Use an execution environment |RE:

Project layout

) Use project folder as root for sources and class files

® Create separate folders for sources and class files Configure default...

Working sets

Add project to working sets

@ < Back Next = Cancel

¢ Then Click Next.
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Change Default output folder from OpenGTS/bin to OpenGTS/build

New Java Project

#ESource |I§Erojects |!°ﬁ|_Jbran'es |%Qrder and Export |

Java Settings . i
Define the Java build settings.

=

= src
= build
=home

=lib

= sampleData

(= war

(= WebContent

[Z .RELEASE_2.0.4

e I | * 1

AR A S A A A

B
®
.
SiS

= jlib 1

<

- Details

&' Create new source folder: use this if you want to add a new source folder to your
project.

&= Link additional source: use this if you have a folder in the file system that should be
used as additional source folder.

2 Add project 'OpenGTS' to build path: Add the project to the build path if the
project is the root of packages and source files. Entries on the build path are visible
to the compiler and used for building.

1 Allow output folders for source folders

Default output folder:
OpenGTS/build|

l | Browse...

=4

@ . <Back | Finish ]| cancel

Then click Finish button
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Import OpenGTS Project

* Select the project just created in the Navigator pane.

File Edit Nawvigate Search Project R

& | B O~ v | @~

| e~

mﬁl

~ 8 OpenGTS
P (= .settings
> = build
&= srrc
P = WebContent
|#] .classpath
%] .project

* Then click File -> Import...
* In the import window select General->File System

Select

Import resources from the local file system into an existing
project.

Select an import source:

type filter text

< [= General
& Archive File
1 Existing Projects into Workspace

L Preferences
b = CVS
b = EJB
P = Java EE
P (= Plug-in Development
P (= Run/Debug

B File System

)>]

[<@

o

Cancel |

¢ Then click Next button
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* Select the directory of OpenGTS package
* Click on the Select All button
* Select Create selected folders only

File system —
Import resources from the local file system. w‘
From directory: |'fhumefuserf0penGTS_2.D.4 W | | Browse... |
» M B OpenGTS_2.0.4 ¥ 2 .RELEASE 2.0.4 .
[ % build_custorm.xml
/| [mb build.properties !
< 2] build.xml
[ CHANGELOG.Cxt
[ = default.conf
[+ LICENSE.txt i
HIterIypes...| | Select All || Deselect All |
Into folder: |'OpenGTS | | Browse...
Options
[] Overwrite existing resources without warning
) Create complete folder structure
® Create selected folders only
k —
3] < Back Finish | | Cancel

¢ (Click on Finish button
WARNING!!

Eclipse doesn't import empty folder, in OpenGTS 2.0.4 the folder ./lib/gtsopt is empty, so we need
to create it.
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Right click on the lib folder then select New -> Folder

= Java - Eclipse Platform

File Edit Source

Refactor

= @ |y Ov Qv | & & G| ® s g

| >

Navigate Search Project Run Window Help

 Package Expl 23 = O

B %

-

= = OpenGTs
PoEsre

b z=bin
b = lib

= opendmtp

P =sampleData
P = war

) build_custom.x

[aub build.propertie

& build.xml

CHANGELOG.t

|2 default.conf

LICENSE.txt

[Z5 AnanRTE Can

P =4 JRE System Library

Go Into

Open in New Window
Show In

Copy

Ez Copy Qualified Name

)
®

Paste
Delete

In the Folder name field, type: gtsopt

New Folder

Shift+Alt+W >

Ctri+C

Ctri+v
Delete

T e 212 rect

9 Project...

#¥ Package

& Class

& Interface

& Enum

@ Annotation
&% Source Folder

15 Java Wcrkinﬁ Set

e

Folder

Create a new folder resource.

Enter or select the parent folder:

|OpenGTS/lib

=
- =) OpenGTS

&= bin
b & build
b = jlib

P = src
P = war

= .settings

= sampleData !

)R,

Folder name: [gtscpt|

Advanced >>

Finish

l l Cancel
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Setup Project Properties

Select in the Navigator pane OpenGTS project
Click on menu Project -> Properties

=

—_— o

Fle Edit MNavigate Segrchﬂun Window Help

| v & | v Ov

J

JEVERS:

Close Project

— | 5w Build Al
m Build Project

~ & OpenGTS

P = settings
P = bin

P = build

P = lib

=

= Build Working Set
Clean...

b = extemalToolBuilders | [ Build Automatically

4] Generate Javadoc...

Properties

Ctri+B |

Select Builders on the left pane, then click on New... button

[type filter text

Resource
Beaninfo Path

ava Build Path
ava Code Style

]
b
P Java Compiler
[> Java Editor
]

avadoc Location
> Task Repository

Task Tags
P Validation

Project References

Run/Debug Settings

Properties for OpenGTS

Builders

Configure the builders for the project:

® & Java Builder

oK

] ‘ Cancel
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e Select Ant Builder, then click OK

Ch 10se configuration type

Choose an external tool type to create:

& Ant Builder

@ [ oK ] | Cancel

1. In the Main sheet complete the following fields:
a) Name: Ant

b) Buildfile: Click on Browse File System... button then select:
On Linux: /home/user/workspace/OpenGTS/build.xml

On Windows: D:/Projects/Eclipse/OpenGTS/build.xml

c) Base Directory: Click on Browse File System... button then select
On Linux: home/user/workspace/OpenGTS/
On Windows: D:/Projects/Eclipse/OpenGTS/

d) Click on Apply

Edit Configuration

Edit launch configuration properties 0
Create a configuration that will run an Ant build file during a build. a —f

Name: [Antl_BuiIder l

El Main " Refresh\| i Targets\| hals Classpatrﬂ hEls Properties\| =i JRE\| ) Environmenﬂ = Build Optionﬂ
Buildfile:
|,fhcme,fuserfwor‘kspace,fOpenGTS,fbuild.xml |

Browse Worksgace...| | Browse File System...| | Variables... |

Base Directaory:

|/home/user/workspace/OpenGTS |

Browse Worlgspace...| | Browse File System...l | Variables... |

[

Arguments:

Variables... |
Note: Enclose an argument containing spaces using double-quotes (").
1 Set an Input handler
| Apply | | Revert |
@ [ 0K l | Cancel |
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file:///media/OS/Users/pigi/Documents/Lavoro/Projects/Eclipse/OpenGTS/
file:///media/OS/Users/pigi/Documents/Lavoro/Projects/Eclipse/OpenGTS/build.xml

2. In the Targets sheet complete the following fields:
a) After a “Clean”: Click on Set Targets... and select clean and all
(WARNING!! Check the rigth order!!).
b) Manual build: Click on Set Targets... and select all.
¢) Auto Build: Click on Set Targets... and select all.
d) During a “Clean”: Click on Set Targets... and select clean.

e) Click on Apply button.

Edit Configuration

Edit launch configuration properties

Create a configuration that will run an Ant build file during a build.

@ —

-

NMame: |'Ant_BuiIder

=] Main |/n§q Refresh |k L Classpatlﬂ <@ Propertieﬂ =i JRE} -} Environmenﬂ = Build Optionﬂ

After a "Clean™

clean, all

Manual Build:

all

Auto Build:

all

During a "Clean":

clean

Set Targets...

Set Targets... |

Set Targets... |

Set Targets... |

l | Cancel
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3. In the JRE sheet complete the fields according the picture below:
ATTENTION: If you use different JDK version, select the SUN JDK, other doesn't works!

(on Fedora you can use openjdk package, see note before).

Edit Configuration

Edit launch configuration properties Q
Create a configuration that will run an Ant build file during a build. 1 =

Name: |:Ant_BuiIder |

=] Main |/n§q Refresh fd; Targets f@e.} Classpath f<|]> Properties ﬁ JRE -] Environmenﬂ = Build Optionﬂ
Runtime JRE:
7 Run in the same JRE as the workspace

@ Separate JRE: ' jdk1.5.0_17 v | | Installed JREs...

() Execution Environment: |Em.rirgnment5...|

VM arguments:

| variahles.. |

Working directory:
® Default:
) Other:
Java executable:
| Apply || Revert |
@ [ OK l| Cancel |
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4. In the Environment sheet:
a) Click on New... button and insert the variables:
e CATALINA_HOME
« JAVA_HOME
* GTS_HOME
* ANT_HOME (optional)

TIPS: You don't need to create ANT_HOME, because is added by Eclipse after first build

b) Select Append environment to native environment
¢) Click on OK
= Edit Configuration

Edit launch configuration properties

Create a configuration that will run an Ant build file during a build.

MName: [|Ant_BuiIder

=] Main [ Refresh [« Targets | Classpath [<2> Properties [=4 |RE | P& Environment

1= Build Options

An environment can only be used when running in a separate |RE.
This setting can be configured on the |RE tab.

Environment variables to set:

Variable Value New...
® ANT _HOME E,.fhome,.fbucolofeclipse}pluginsfarg.apache.ant_l.]‘ Select...
® CATALINA_ HOME ;!optftumcatS

® GTS_HOME ;jhomejuser}workspacef@penGTS

@ JAVA HOME E,fusr,fjava,fjdkl.s.n_n

® Append environment to native environment

_' Replace native environment with specified environment
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On Windows:

= Edit Configuration -

g -

Edit launch configuration properties

Create a configuration that will run an Ant build file during a build.

@

MName: ANt

IEl Main ﬁgﬂ Refresh (yﬂ% Targets ({5‘4} Classpath |/<EI> Properties (!'& IRE rﬁ Environment 1= Build Options\l

Environment variables to set:

An environment can only be used when running in a separate JRE.
This setting can be configured on the JRE tab.

Variable

& ANT_HOME
® CATALINA_HOME
® GTS_HOME
@ )JavA_HOME

Value

C\Program Files (x86)\apache-ant-1.7.0
C:\Program Files (xB6)\Apache Tomcat 6.0
D:\Rozne\Projekty’\Eclipse\OpenGT5_2.1.8
C\Program Files\Java'jdkl.6.0_17

Mew...

@ Append environment to native environment

(") Replace native environment with specified environment

* Unselsect Java Builder then click OK

Properties for OpenGTS

Edit...

Remove

|itype filter text |

Resource
Beanlnfo Path

Java Build Path
Java Code Style

R

Java Compiler

=

Java Editor

Javadoc Location

Project References

Run/Debug Settings

P Task Repository
Task Tags

> Validation

k

Builders

Configure

the builders for the project:

[ [@ Java Builder |

¥ & Ant_Builder

- Import... |
Edit.. |

| Remove |

oK H Cancel |
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Compile OpenGTS

* Click on Project -> Build Project

e Java - Eclipse Platform
Fle Edit Source Refactor Navigate Search BEGlEgd Bun  Window Help
| 3w G v Ov Qv | & B Gy _
Close Project
| o
Ms - s Build All Ctri+g —
Build Project
k= ¥ Build Working Set >
b @ src [] Build Automatically
b =\ JRE System Library @) Generate Javadoc...
P = hin
b= lib _
< = lib Properties

* In the Console pane, you must read after some printed rows: BUILD SUCCESFUL

L |
x % & GgE = Civ = 0

~
| &

<terminated= Ant_Builder [Ant Builder] fusr/java/jdk1.5.0_17/bin/java (15/gen/2009 18:11:57)
Qclel:

[echo] 'gclBl.war' created.
gprmc. compile:
[echo] Compiling 'gprmc.war' servlet ...
d [mkdir] Created dir: shome/user/workspace/OpenGTS/build/gprmc
[mkdir] Created dir: /home/user/workspace/0penGTS/build/gprmc/WEB-INF
[mkdir] Created dir: /home/user/workspace/0OpenGTS/build/gprmc/WEB-INF/classes
[mkdir] Created dir: /home/user/workspace/OpenGTS/build/gprmc/WEB-INF/tlds
[javac] Compiling 1l source file to /home/user/workspace/OpenGTS/build/gprmc/WEB-INF/classes

[copy] Copying 1 file to /home/user/workspace/OpenGTS/build/gprmc

[copy] Copying 1 file to /home/user/workspace/OpenGTS/build/gprmc/WEB-INF

[copy] Copying 2 files to /home/user/workspace/0OpenGTS/build/gprmc/WEB- INF
gprmc. war:

[echo] Creating 'gprmc.war' archive ...

[war] Building war: /home/user/workspace/OpenGTS/build/gprmc.war

gprmc:
cho

lecho
compile:
echo] Libraries compiled ...
ech

'gprmc.war' created.

lall:

o] Build 'all' complete.

BUILD SUCCESSFUL
Total time: 13 seconds

11

¢ 2>
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On Windows:

<terminated= ANt [Ant Builder] C:\Program Files\Java'jref'bin'javaw.exe (2009-11-27 21:20:33)

gpIme:
[echo] 'gprmc.war' created.
gpsmapper.compile:
[echo] Compiling 'gpsmapper.war' servlet

[mkdir] Created dir: D:\Rozne\Projekty\Eclipse\CpenGIS 2.1.8\build\gpsmapper

[mkdir] Created dir: D:\RoznehProjekty\Eclipse'\CpenGIS 2.1.8\build\gpsmapper\WEB
[mkdir] Created dir: D:\RoznehProjekty\Eclipse'\CpenGIS 2.1.8\build\gpsmapper\WEB
[mkdir] Created dir: D:\Rozne\Projekty\Eclipse\CpenGTS 2.1.8\build\gpsmapper\WEB
[javac] Compiling 1 source file to D:\RoznehProjekty\Eclipse'OpenGI5 2.1.8%build
[copy] Copying 1 file to D:\Rozne\PFrojekty\Eclipse\CpenGTS 2.1.8\build\gpsmappe
[copy] Copyving 5 files to D:\Rozne\Projekty\Eclipse\OpenGI5 2.1.8\build\gpsmapp
[copy] Copying 2 files to D:\Rozne\Projekty\Eclipse\CpenGIS5 2.1.8\build\gpsmapp

gpSmAppEY . War:

[echo] Creating 'gpsmapper.war' archive ...
[war] Building war: D:\Rozne\Projekty\Eclipse\OpenGIS 2.1.8\build\gpsmapper.wa
gpSmapper:

[echo] 'gpsmapper.war' created.
compile.servliets:

[echo] Servlet/War file compiled
compile:

[echo] Libraries compiled
all:

[echo] Build 'all' complete.

BUILD SUCCESSFUq
Total time: 2 minutes 52 seconds

NOTE:

Remember that Eclipse don't want to build again if you didn't make any changes to source code.
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Run template server inside Eclipse

* Add into your build.xml or build_custom.xml a new target like this:

<target name="template.run" depends="template"
description="Run 'Device Communication Server' template ...">
<echo message=" template run ..."/>
<java fork="true" classname="org.opengts.servers.template.Main">
<arg value="-conf=${Env.GTS HOME}/default.conf"/>
<arg value="-start"/>
<classpath>
<path refid="compile.classpath"/>
<path location="${build.lib}/template.jar"/>
</classpath>
</java>
</target>

* Open Run —> External Tools —> External Tools Configurations

® Select Ant Build then click on New launch configuration button

& External Toeols Configurations + X
Create, manage, and run configurations Q
Run an Ant build file. R —:;j
‘; o Sev Configure launch settings from this dialog:

‘*m ew launch cunﬁgurat\un [ - Press the 'New' button to create a configuration of the selected type.
|Z| - Press the 'Duplicate’ button to copy the selected configuration.

T, Program ¥ - Press the 'Delete’ button to remove the selected configuration.

% - Press the 'Filter' button to configure filtering options.

- Edit or view an existing configuration by selecting it.

Configure launch perspective settings from the Perspectives preference page.

Filter matched 2 of 2 items

@ Close
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m&h Rffreshw ab Build\l @ﬂ% Targets\l {5‘4} Classpathw L1 Pmpen:ies.\l -‘LIRE\I ﬁ Environment\l E=| CummonT

Add a new ,Ant Build Configuration“ and set

O Name: “template.xml”

© Buildfile: “/home/user/OpenGTS/build.xml”

© Base Directory: “/home/user/0penGTS”

Name:  termplate.xml

Buildfile:

| fhomefUser/OpenGTS/build.xml

( Browse Workspace... J ( Erowse File System... ) ( Variables... )

Base Directory:

I /home [User/Open GI'S,.!‘|

[ Browse Workspace... j ( Browse File System... J [ Variables... J

Arnnmaentc:

Select under Tab ,Targets” template.run Ant-Target

Create, manage, and run configurations

Ru

n an Ant build file.

Q

=

TEX|E®
LT &S X S Name: | template.xml
| type filter text |
& =] Main (néh Refresh | 37, Build M&‘} Classpath] <@ Pmperties] ﬂjklﬂ 43 Environmenq =] Cornmon]
¥ i Ant Build
£ template.xmi Check targets to execute:
{E Program " |Name Description
] & gpsmapper Compile/Create "gpsmapper.war' |y
B ‘ gpsmapper.compile Compile ‘gpsmapper.war’ source
=] .gpsmapper.war Create 'gpsmapper.war' archive
B ‘ gpsmapper.deploy Deploy 'gpsmapper.war’ to Tomcat
[ @ template Create 'Device Communication Server' template ...
E @ ternplate.run Run 'Device Communication Server’ template ...
[] @ template_old Create [OLD] 'Device Communication Server' template_old ... a
O @ icare Create 'Device Communication Server' I-CARE G3300 ...
O @ tools Create Miscellaneous tools ... i
=] ' systemProps Print System Properties v
I
1 out of 71 selected
(] Sort targets
[C] Hide internal targets not selected for execution
Target execution order:
template.run (W\:
Apply Revert
Filter matched 3 of 3 items

@

( Close J _
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* Set on Tab ,Environment” the GTS HOME variable like ,Base Directory“

Name: |tempfale.xmf

[=] Main (qgh Refresh ﬂu:j Build (‘&- Targets (4}4} Classpath F<I:I> Properties (.?'L JRE m@&:ﬂ

This setting can be configured on the JRE tab.

Environment variables to set:

An environment can only be used when running in a separate JRE.

Variable

= GTS_HOME

Value
fhome/User/OpenGTS/

B Append environment to native environment

() Replace native environment with specified environment

e LApply” and ,Close”

Select...

* Now you can Run your template server in eclipse starting from External Tools

B | B3 0 Qr |GG @S 7] 4@ R |2 Gt bre

£ fhea [Sina

T4 Project Explorer 58
# las GMIpsErv.jar

Ble~ -0 @huud;usm

m.xml

[ %) buttaxmi 58

=g

<FTLESEE aLr="3{0U11a. nOME} >
<include name-"org/opengts/servers/*.class"/>
<include name="org/opengts/servers/template/**/*. class"/>
</Fileset>

P o MotoDMTP.jar <hyer
P B JRE System Library JVM 1.6.0 (MacOS X Default)] </targets
» G bin @  ctarget namss*tenplatesrui depends="etet
b (= build description="Run "Device Communication Server® template ..."s
» G lib <echo message="rts run ..."/>
> elib 2 <java fork="true" classname-"org.opengts.servers.template.Nain">
» o <arg value="-conf=${Env.GTS_HOME}/default.conf" />
5 Mot TP <arg value="-start"/>
= classpaths
¥ (= private <path refid="compile.classpath’ />
¥ Ewar <path location-"${build.lib}/template.jar" />
b (= events </classpath>
b (=gclol </javas
> = gprme </target>
¥ (= gpsmapper €l i
» = mologoge sl s
b (track

(5] build_custom.xm|
ah build.properties.
) build.xmi
‘CHANGELOG. txt
B common.conf

B config.conf

' custom.conf

[B) deservers.did

¥ drcanare vl

«<1-- Target: [0LD] Device Parser Module example template -->

=

e (=)

[2 Markers ﬂj Properties Mﬂ Smm] % Data Source Exp\or:a B Smppet;] & s-mﬂ ¢ vmgmsq

= B-09-— 0

No consoles to display at this time.

* Console window show the output

[Z1 Markers (E Properties

& Senrers} m Data Source Exploreq B Snippets} & Searth\l =y Progresq

=0

template.xml [Ant Build] jSystem/Library/Frameworks/JavaVM.framework /Versions/1.6.0/Home/bin/java (04.12.2009 01:5 | X % | |:=—\“ EE|§||E|H = Bl

template.run:

[echo] template run ...

[java] [INFO_112/04 @1:57:22|5tartupInit.prelnitialization:98] [Memory(K) max=83392, total=8128@, free-78954]

[java] [INFO_112/@4 @1:57:22|BasicPrivatelabelloader.printInfo:329] Privatelabelloader class: org.opengts.war.tools.Private
[java] [INFO_112/04 @1:57:23IMain.main:177] -------mmmmmm oo -
[jova] [INFO_112/04 @1:57:23IMain.main:178] Template Exaomple Device Parsing Module Server Version @.2.3

[java] [INFO_112/@4 @1:57:23IMain.main:179] Devicelode : template

[java] [INFO_112/@4 @1:57:23IMain.main:180] ParseFormat : 3

[jova] [INFO_112/04 @1:57:231Main.main:181] MinimumSpeed: 4.0

[java] [INFO_112/@4 @1:57:23IMain.main:182] EstimateOdom: true

[java] [INFO_112/@4 @1:57:23IMain.main:183] Copyright 2087-2009, GeoTelematic Solutions, Inc.

[java] [INFO_112/04 @1:57:23IMain.main:184] ------emememme e e e e e e e e e e e e
[java] [INFO_112/@4 @1:57:311TrackServer._startTCP:243] Starting TCP listener thread on port 31200 [timeout=150@@ms] ...
[java] [INFO_112/@4 @1:57:311TrackServer._startUDP:2797 Starting UDP listener thread on port 31200 [timeout-60000ms] ...

-
¥

S—
LA

‘
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Debug remote tomcat application using Eclipse

Eclipse can connect to Tomcat and give you the ability to debug your WAR applications.
This document describe some basic setup to start tomcat in debug mode and use Eclipse, for more
information see tomcat and Eclipse documentation.

¢ Start tomcat in debug mode:

Default starting script is catalina.sh (or catalina.bat) under Tomcat bin directory.
Use the parameter jpda to start tomcat, this run in debug mode and use the port 8000 (default
configuration) to give to external debug program all information needed.

Simple run:

> ,/catalina.sh jpda start
or in Windows 0S:

> catalina.bat jpda start

Under Fedora (Release 11) starting script is /usr/bin/dtomcat5, so run:
> /usr/bin/dtomcat5 jpda start

TIPS: to show all starting options run: catalina.sh -h (or without parameters)
You obatin something like this:

Found JAVA HOME: /usr/lib/java

Please complete your /etc/tomcat5/tomcat5.conf so we won't have to look for it next time
Using CATALINA BASE: /usr

Using CATALINA HOME: /usr

Using CATALINA TMPDIR: /usr/temp

Using JRE_HOME:

Usage: dtomcat5 ( commands ... )
commands:
debug Start Catalina in a debugger
debug -security Debug Catalina with a security manager
jpda start Start Catalina under JPDA debugger
run Start Catalina in the current window
run -security Start in the current window with security manager
start Start Catalina in a separate window
start -security Start in a separate window with security manager
stop Stop Catalina
stop -force Stop Catalina (followed by kill -KILL)
version What version of tomcat are you running?
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® Create debug profile in Eclipse
Select the OpenGTS project in the Navigation pane

Open the Java perspective

C/C++

CVS Repository Exploring
35 Debug

7 Java Browsing

2! Java Type Hierarchy
& JavaScript

<J= Plug-in Development

8 Remote System Explorer

[75 Resource (default) k
£9 Team Synchronizing
& Web

oK I | Cancel

Make sure that Java icon is showed in the upper right corner

Select from menu bar Run->Debug Configurations

Search Project Window Help

o G J & @, Run Ctrl+F11
%, Debug F11

=)

Run History >
Run As b
Run Configurations...

Debug History >
Debug As
Debug Configurations...

Select Remote Java Application than click on the new button to create a New launch configuration

Debug Configurations

Create, manage, and run configurations

Attach to a Java virtual machine accepting debug connections

|ﬁl B v Configure launch settings from this dialog:
— . .
\typ Mew launch configuration |7 - Press the 'New' button to create a configuration of the selected type.
|5 - Press the 'Duplicate’ button to copy the selected configuration.

T C/CF+ Attach to Local App
[E] C/C++ Local Application X - Press the 'Delete’ button to remove the selected configuration.
[t] C/C++ Postmortem debugi o - Press the 'Filter' button to configure filtering options.

@ Eclipse Application - Edit or view an existing configuration by selecting it.

[ HTTP Preview

~ [3] Java Application
New_configuration
Track
Ju Junit
Ji Junit Plug-in Test
% 0SGi Framework

~ B Remote Java Application

2, Track (1)

f[eC

] 2]
Filter matched 14 of 14 items

Java Applet Configure launch perspective settings from the Perspectives preference page.

Close

Page 23 of 25



Name: assign the name for the debug configuration
Project: select the OpenGTS project

Host: the host name where tomcat run or localhost
Port: 8000 is the default jpda port

@ Project does not exist

Create, manage, and run configurations

B x| B8 3

|type filter text |

[E] C/C++ Attach to Local £
[€]C/C++ Local Application
[E]C/C++ Postmortem deb
& Eclipse Application
B HTTP Preview
[l Java Applet
= [3] Java Application
1 New_configuration
T Track
Ju JUnit
Jii Junit Plug-in Test
# 0SGi Framework
< [Z, Remote Java Application

= Debug OpenGTS -
b

1 Femmle 090

[0 7 3>]
Filter matched 15 of 15 items

Name: | Debug OpenGTS

wﬁy Saurce] = Qammarﬂ

Project:

|openGTs

|[ Browse... l

Connection Type:

[Standard (Socket Attach)

v

Connection Properties:

Host: |localhost

Port: |8000

[] Allow termination of remote ¥M

@

Add a new source path

Name: |Debug OpenGTS

Select Workspace folder

8% Connect E& ﬁﬂuﬁ i I’_zlgommorﬂ

Source Lookup Path:

Select the type of source to add to the source lookup path

A folder in the workspace

M

45 Absolute File Path

) Archive

) External Archive

(= File System Directory
@ Java Classpath Variable
=i Java Library

=* Java Project

[ Dot n
= Path-Mapping

@ |

Cancel

1

Remove
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And choice the src folder of OpenGTS project

Choose folders to add:
P = .settings 2
P = bin

P = build

I = Docs

b = jlib

b = lib

P = logs

P = MotoDMTP
b = private

I = sampleData

¢ & SrC

P &= war
I =2 RemoteSystemsTempFiles H

Search subfolders

@ oK Cancel
LS

Note: Probabily you must add the war folder too (I have not tested deeply).
Now press F11 on your keyboard or select Run->Debug.
Eclipse ask to you to open the Debug prospective then run you war application on the remote

tomcat server and show all debug informations.
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